[ts-gen] TWS riskfeed.jar

R P Herrold herrold at owlriver.com
Wed Jan 30 11:51:22 EST 2008


On Tue, 29 Jan 2008, Tony Raymond wrote:

> I appreciate your posting to resolve the Riskfeed.jar issues 
> with TWS.  The only drawback is I am not very tech savvy, 
> and cannot implement your advice.

> If you have time, please let me know where / how to insert 
> this info, or direct me to the approprate site.

I set forth a full analysis below; short answer is: it 
appears that IB has issued a new TWS jarball, which fixes the 
matter by providing the missing file.

> Tech support at IB have been unhelpful up to this point....?

** shocking** TAC clueless?  ;)

Frustratingly, the ticket I opened with TAC was silently 
closed with their new seven day autoclose system, and no 
mention of the fix.  ;(


The 'missing' riskfeed.jar needs to go into the ./IBJts/ 
subdirectory.

[herrold at centos-5 temp]$ find . -name riskfeed.jar
./IBJts/riskfeed.jar

Perhaps IB has fixed it with the new release a few days ago. 
Let's see:

1.  I run a script to pull the latest unixmacosx.jar from 
upstream:

[herrold at xeon temp]$ ./GETNEW
     <snip ... >

2.  I remove any riskfeed.jar which I have about, and take a 
backup of my config files

[herrold at xeon temp]$ rm -f `find . -name riskfeed.jar`
[herrold at xeon temp]$ ./new-unix.sh
  dhunsrszu darrkq dhunsrzwq dfqlrdtdr dfqlrdwdq
now please run: jar xf unixmacosx.jar

3.  I verify that I do not have ANY riskfeed.jar about in the 
TWS executable path

[herrold at xeon temp]$ find . -name riskfeed.jar
[herrold at xeon temp]$

4.  I take a checksum of the newly pulled unixmacosx.jar

[herrold at xeon temp]$ md5sum unixmacosx.jar
49c93d7bc674ec80271dbefab824839c unixmacosx.jar

5.  I know from other machines that it is the 881.7 release, 
so I rename it into my archive

[herrold at xeon temp]$ mv unixmacosx.jar unixmacosx_881.7.jar

6.  and unpack it into ./IBJts/

[herrold at xeon temp]$ jar xf unixmacosx_881.7.jar

7.  Now when we check, we find a riskfeed.jar

[herrold at xeon temp]$ find . -name riskfeed.jar
./IBJts/riskfeed.jar
[herrold at xeon temp]$

8.  Just to be sure it came from unixmacosx_881.7.jar, I rm 
it, and re-unpack unixmacosx_881.7.jar

[herrold at xeon temp]$ rm -f ./IBJts/riskfeed.jar
[herrold at xeon temp]$ jar xf unixmacosx_881.7.jar
[herrold at xeon temp]$ find . -name riskfeed.jar
./IBJts/riskfeed.jar

9.  look at its datestamp:

[herrold at xeon temp]$ ls -al ./IBJts/riskfeed.jar
-rw-rw-r-- 1 herrold herrold 68006 Jan 25 09:53 ./IBJts/riskfeed.jar


[herrold at xeon temp]$ run-tws
11:07:24:513 JTS-Main: Build 881.7, Jan 24, 2008 9:25:50 AM
[herrold at xeon temp]

9.  and test that it works

[herrold at xeon temp]$ run-tws
11:07:24:513 JTS-Main: Build 881.7, Jan 24, 2008 9:25:50 AM
    ...

======================================

So, it appears that IB has re-added the missing riskfeed.jar 
in the latest upstream Unix release

Note that your TWS starting script has to add the riskfeed.jar 
to the classpath

This little script will work to start the TWS, when run just 
above ./IBJts ;  remember to make it +x if you clip and use 
it.

-----------><-----------snip---------><----------
#!/bin/sh
#
#       wget http://www.interactivebrokers.com/download/unixmacosx.jar
#       jar xf unixmacosx.jar
#
JFREE="1.0.0"
JCOMM="1.0.0"
JPLUG="pluginsupport.jar"
#       rss.jar new at 856.5
#       riskfeed.jar new at 881,x
JREST="jhall.jar:other.jar:rss.jar:riskfeed.jar"
#
#
cd IBJts
java -cp \
   jts.jar:jcommon-${JCOMM}.jar:jfreechart-${JFREE}.jar:${JREST}:${JPLUG}  \
   jclient.LoginFrame .
-----------><-----------snip---------><----------


Please join the mailing list, and ask there, if this does not 
work for you, and we'll diagnose further.

-- Russ herrold


More information about the ts-general mailing list