[ts-general] CentOS 6, Additional database build issue

Paul paul.analytic at gmail.com
Sat Aug 25 10:50:44 EDT 2012


On Sat, Aug 25, 2012 at 06:59:54AM -0700, Harry Balzer wrote:
> my shimrc file isn't identical:
> 
> let DbmsHost = localhost,
> ApiLevel = 23;
> 
> feedhost commented out a little lower:
> 
> #FeedHost = localhost,
> 
> comments suggest this is already default, so not sure if i need to add it as
> you have.  i've looked at ib's documentation
> and my gateway configuration, can't find what "version" of the API it's using,
> but i'm guessing this is where it's breaking.
> i'm wondering if the shim's api levels ib specified ... ?
> 
> i have tried firing the shim with your specified settings and got the same
> complaint.

I've downloaded the lastest version of the IB gateway, and it
now gives me errors too (although not the same as your error):

#           The trading shim has connected to the database server and
#           loaded   8199 products.  Read:    1    6   19 <15>
# Problem: 403 probe failed: no rule exists for index 15
# 
# 1|DU31817|9|1|1|
# 
# Problem: 524 the IB tws server version is contradictory
# Exiting

So it looks like a problem with 'the IB tws server version'

I'll try the latest TWS (non-gateway) later,

Paul


More information about the ts-general mailing list